
  
 
 
 
 

 
 
 
 
 
 
 
 
 
 

How to Excel with CUFS  
 
Part 1 

 
 

 
 
 
 
 

 
 

Course Manual          Finance Training 

 
 
 
 
 
 
 
 
 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

  



   
   

   



Contents 
 
 
 
1. Extracting data from CUFS 
1.1 Obtaining data by using on-line enquiries     1 
1.2 Summary Templates        2 
1.3 Customising your enquiry view using folder tools    3 
1.4 Exporting your enquiry       3 
 
2. Excel Toolbars, Navigation and Formatting 
2.1 Customising Excel tool bars      6 
2.2 Moving around large spreadsheets     7 
2.3 Working with foreign currencies and reconciling    7 
2.4 Formatting date fields       7 
2.5 Formatting columns’ width            8 
 
3.      Functions 
3.1 Extracting data from existing cells: the ‘Mid’ function   9 
3.2 Using a formula to convert debits and credits    10 
3.3 Find function         11 
3.4 Find and Replace Function       11 
3.5 To copy cell contents/formula quickly     12 
3.6 Copy/Paste Special        12 
 
4. Data Functions  
4.1 Sorting Data         13 
4.2 Removing unwanted lines       14 
4.3 Sub-totalling         15 
4.4 Filtering         17 
4.5 Text to column        19 
 
Appendix:           
 
Excel navigation keys        20 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

HTEWC Pt 1 Manual Oct09 v2.1 



Default type is 
GBP (£) 

Users can choose a single month 
e.g. MAY-06 to MAY-06 or a range. 
When choosing a range, users can 
also cross financial years if desired 
e.g. JAN-06 to DEC-06

1.  Extracting Data from CUFS 
 
 
1.1 Obtaining data by using online enquiries  
 
 
The General Ledger (GL) module allows you to review detailed balances and 
transactions within your accounts on screen.  Online account enquiries can be used 
for various purposes, such as:  
 
• Reviewing income/expenditure balances on a particular account or range of 

accounts 
• Looking at expenditure against budgets (variances) and then “drilling down”. 

To see the detail behind the balances 
• Review invoices posted from Accounts Payable to a general ledger account; 
• Look at income posted from Accounts Receivable into trading/donations accounts 
 
In CUFS, from your GL Navigator screen: 
 

Enquiry    Account 
 
In the Account Enquiry screen you will need to decide whether you want to look at a 
range of accounts or just one specific account, e.g.  U.PD.PDBA.AAAA.ERNA.0000 
Fill in the boxes as follows: 

 
 
 
 
 

Select 
desired 
unit  of 
display 

To query back 
more than one 
code combination 
in a single line, use 
a Summary 
template (see 1.2 
below) 

If required 
change from 
Actual to 
budget or 
Encumbrance  
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1.2 Summary Templates 
 
 
Templates allow you to group together and obtain balances for the following account 
code combinations: 

• transactions for a particular cost centre and source of funds combination 
• all transactions on a particular cost centre 
• all transactions on a particular source of funds 
 

Using the highlighted example 
D.D.D.D.T.T: 
 
Where there is a D, you fill in 
the codes: 
 
1st D  =   Entity (e.g. “U” for 
   University) 
2nd D  =   Dept Code(s) 
3rd  D  =   Cost Centre(s) 
4th  D  =  Source(s) of     
   Funds 
 
Where there is a T, leave the 
codes blank, CUFS will retrieve 
all combinations. 

 
 
 

1 D.D.D.D.T.T.  

 

This template will select every transaction code 
combination against specified department, cost centre 
and source of funds codes 
 

 
2 

 
D.D.D.D.TIE.T 

 

As 1 above, but further limited to transaction codes for 
Income and expenditure only (TIE) e.g. transaction codes 
such as XEAA (brought forward balances) are excluded. 
 

 
3 

 
D.D.D.T.T.T.  

 

This template will select every source of funds and 
transaction code combination against specified 
department and cost centre codes. 
 

 
4 

 
D.D.D.T.TIE.T 

 

As 3 above, but further limited to transaction codes for 
Income and expenditure only (TIE) e.g. transaction codes 
such as XEAA are excluded. 
 

5 D.D.T.D.TIE.T 

 

This template will select every cost centre and every 
income and expenditure transaction code 
combination against specified department and cost 
centre codes. 
 
Note:  Only available for Central Administration users 
 

 
Click on the Show Journal Details button to view the transactions and use folder 
tools to customise the view of the data before you export it to Excel. 
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1.3 Customising your Enquiry view using Folder Tools 
 
 
Folders allow you to customise/personalise the layout of the screen, and are available 
when the folder icon or folder menu appears.   
Custom folders are specific and unique to the user 
 who creates them  
 

New Folder 

Save Folder 

Move 
Column to 
Left 

Move 
Column to 
Left 

 
Widen or 
narrow a 
column 

      Open 
      Folder 

Delete Folder

Hide Column 

Show  
Column 

Move Column to Right 
 
All these functions can also be accessed from the Oracle menu item called “Folder” 
 
To Save a folder view: 
 
1. Select New from the ‘Folder’ menu. 
2. Give your folder a name in the Folder field. (E.g. Phil’s Export Screen) 
3. If you want this folder view every time you view this screen, tick the ‘Open as 

Default’ box 
4. Click on the Folder icon on the Toolbar to open the Folder Tools toolbar shown 

above. 
5. Customise your folder by moving, unhiding, hiding, and resizing columns using the 

Folder Tools. 
6. Click on the “Save” icon when you have finished customising. 
 
 
1.4 Exporting your Enquiry 
 
 
From the Menu bar choose: File    Export 
 
If you have more than 100 records, you will see this screen. Select Continue to End. 
All the records will be retrieved and a red progress bar will show the % completed. 
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When the export has completed you will see the following window: 
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Save the file in an appropriate place, with a file name of your choice but retaining the 
.tsv file type. 
 
Now open up Excel, find and open your file remembering to change the file type to All 
Files – so you can see the .tsv file types as well. 

 

 
 
 
Now work through the ‘Text Import Wizard’ steps… 
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Each of 
these small 
squares 
represents 
a tab in 
Excel.  
 
Therefore, 
our data is 
‘delimited’. 
 
Just click 
on Next. 

 
 

Format the Period Name as a date field and then click on Finish. 
 
 

 
 
 
Your data will then be displayed in an Excel spreadsheet, however it still is a ‘text.’ 
file, so resave and change the file type to a Microsoft Excel workbook. 
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2. Excel Toolbars, Navigation and Formatting 
 
2.1 Customising Excel Toolbars 
 
 
It is sometimes useful to customise your toolbar in Excel so that you have icons 
displayed for the functions that you are likely to use on a regular basis.  
 

 
 
 
 
 
 
 
 
 
 
 
 
 

On the menu 
choose: 
 
 Tools, 
 Customise. 
 

 
 
 
 

 

• Select Commands tab and 
then choose a category 

• Click onto the command 
you would like to see on 
the toolbar and drag it onto 
the tool bar at the top of 
your screen. The icon will 
appear on the toolbar from 
now on.  

• Click remove an icon, 
repeat these steps. When 
the commands window is 
open (as left) drag any 
unwanted icons from the 
toolbar and drop anywhere 
in the commands window. 
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2.2 Moving around large spreadsheets 
 
 
1) Selecting/highlighting a block of data: 
 
Position the cursor in the first cell of the block (top left) 
With the SHIFT key held down, press and release the End key and then the right 
arrow key then the down arrow key.   
 
2) Going to last cell containing data (the bottom right corner): Ctrl + End 
 
3) Returning to the top of your spreadsheet:    Ctrl +Home 
 
Note:  More quick keys are listed in the appendix at the back of this manual 
 
 
2.3 Working with Foreign Currencies & Reconciling 
 
 
Before you start to manipulate the data in Excel you should ensure that it still 
reconciles back to CUFS – use the Autosum ( ∑ ) function to calculate a total and 
compare back. 
 
Be really careful when dealing with foreign currencies in CUFS 
: 
• Entered debits is the foreign currency value whereas  
• Accounted debits is the sterling value. 
 
 
 
2.4  Formatting Date fields 
 

 

 

Often it is useful to reformat date 
fields in Excel: 
 
• For presentational purposes 
• To allow individual days within 

a month to be grouped together 
 
To do this  
1. Highlight your date column  
2. Select Format > Cells from the 

menu  
3. Within the number tab pick your 

required format  
4. Click OK 

 
 

HTEWC Pt 1 Manual Oct09 v2.1  7 



   
   

 
2.5 Formatting columns’ width 
 
 
All Columns 
Once exported into Excel you can quickly format all the columns on your spreadsheet 
by clicking on the top left hand box to highlight the whole spreadsheet and then      
 either: 
 

a) Format menu  Column  Autofit Selection;  
 
or alternatively: 
 
b) place your cursor on the vertical line between columns  (e.g. C)  and its right 

hand neighbour (e.g. D) your cursor should change into a  cross symbol and 
then double click 

 

 
 
 
Just One Column 
Click in any single cell in the sheet (so nothing is highlighted). 
Then, to adjust any single column width, follow the instruction in b) above on the 
column you wish to change. 
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3. Functions 
 
 
3.1 Extracting data from existing cells: the ‘Mid’ function 
 
 
This is a particularly useful way of extracting the details of just one segment from an 
account code string, e.g. the cost centre 
 
a) Insert a new column ready for your new data and give it a column title 
b) Click into a cell in your new column and enter the formula: 
 

=mid(F2,6,4) 
 
F2 is the cell containing the source text 
6 tells the formula to start at the sixth character in the text 
4 indicates the number of characters to capture  

 
 
Also:  Using LEFT and RIGHT formulas 
 
Similar to the Mid function, you can also capture text at the beginning and end of a 
cell by using LEFT and RIGHT formulas.  
 
Looking at cell F2 in the screen shot above, to capture the nine characters 
U.NA.NAFH at the beginning of the cell use the LEFT formula:    
 

=LEFT(F2,9) 
 

To capture the last nine characters LKAA.0000 use the formula:   
 

=RIGHT(F2,9) 
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3.2 A quick way to put the debits and credits into a single column 
 
 
The debits and credits are exported from the CUFS general ledger enquiry screen in 
two columns and they are both presented as positive numbers. In Excel, you want the 
credit values to be minus numbers and you want all the values in a single column. A 
simple and reliable way to do this is as follows: 
 
a) Ensure there is a blank column to the right of the “Accounted Credits” column. 
To  illustrate, let’s  say the new column is column J 
b) Name the new column “Amount” 
c) In cell J2, enter the formula       =h2-i2 
 

 
 
 
 
For each line of data, there will only be a value in either the debit column or credit 
column, never in both, so the result of the formula will be a plus figure for debits and a 
minus figure for credits. 
 
d) Copy this formula down to the last row of data 
 
The debit and credit columns are no longer needed but before you delete them,  
turn the formulas in the new Amount column (which are dependant on columns H and 
I)  into values 
 
e) Highlight the whole of column J, select Copy, Paste Special, Values. This 

overwrites the formulas with plain numbers. See Section 3.6 for more 
 
f) Delete the debit and credit columns. 
 
You now have one row of numbers, debits are positive, credits are negative,  now 
Sum the column to make sure the total is still correct.
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3.3 Find Function 
 
 
Use Ctrl F (Find) or the binoculars icon on the toolbar to find a value or text anywhere 
in the spreadsheet. In this example we are searching for the value 1.74.  
Type the value into the find what box then click on the Find Next button. If the value 
exists, it will go to the cell, you can then press “Find Next” again to see if there are 
any other cells containing 1.74, and so on. 
 
 

 
 
Click on close to clear the Find box. 
 
3.4 Find and Replace Function 
 
 
In addition to finding a value or text, you can then replace it with something 
else. You can also replace blank cells with a value. 
 
In our data exercise we want to replace blank cells in the debit and credit column with 
zeros. 
 
1)  Highlight worksheet cells where you want to use Find and Replace  
 
2) Use the quick keys Ctrl+H – bringing up the Find and Replace window 
 
3) Find what:  leave it blank (i.e. find blank cells) 
 
4) Replace with: 0 
 
5) Click on the Replace all button 
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3.5 To copy cell contents/or cell formula quickly  
 
 
 

a) Highlight the cell  
you want to copy 
 

b) put your cursor on the 
bottom right hand 
corner of the cell’s box 
so that you see the 
following symbol: 

 
 
 
c) depress the left hand 

button of your mouse 
and keeping it pressed, 
drag it down over the 
cells where you want 
the information copied 
into. 

 
 
 
3.6 Copy……Paste Special……Values 
 
 
Instead of just Copy…Paste, try Paste Special. This function allows you to: 
 
 
a) copy  a formula from one cell to another 

 
b) copy just the value from a cell, i.e. 

removing the formula behind the value 
 
c) copy a comment from one cell to another 
 
d) highlight that you want to paste just the 

‘values’ and click OK 
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4.  Data Functions 
 
 
4.1 Sorting Data 
 
 
There are a variety of reasons why you may want to sort your spreadsheet in a 
particular order e.g. 
 
• to put in date order;   
• rearrange alphabetically,  
• to rearrange in numeric value  
• to collate together lines of information you do not need so you can delete them 

quickly and easily 
 
This instruction assumes your data has column headings (called the header row). 
 

 
 
 
 
 
 
 
 

 
 
 
 
 

To do: 
 
1. Highlight the whole 

spreadsheet  or the block of 
data you wish to sort 

 
2. Select Data> Sort from the 

menu 
 
3. remember to click the circle, 

saying that your data includes 
a Header Row 

 
4. Tell Excel which columns to 

sort by (you can select up to 
three) 

 
5. Click on OK 
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4.2 Removing unwanted lines 
 
 

 
 

 

To get rid of unwanted 
lines: 
 
 
a) highlight the 

whole 
spreadsheet 

 
a) Select 

Data Sort 
 

Ask the system to sort the data as per 
one of the columns where you know 
there is data that you want  (e.g. in the 
example shown by column B) 
 

Delete the lines from 
the spread sheet that 
you don’t need… 
 
 Highlight lines 
 Select Edit  

Delete 
 
Repeat as necessary  
 
(NB, the F4 button 
repeats the function – 
in this case the line 
deleting) 
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4.3 Subtotalling 
 
 
Sub-totalling is a very easy to use tool but first you must make sure: 
 
a)  the data is sorted in the way you wish to subtotal – if you want to subtotal by 

cost centre, the data should be sorted by cost centre 
b) columns with dates in them are actually formatted as dates, otherwise they 

will sort alphabetically rather than chronologically 
 
 

 
 
 
Excel will create subtotal rows within the data. They are special formulas that are 
placed at the end of each month. The left edge of your worksheet will look different, 
giving 3 options at the top of the sheet for choosing the level of detail you wish to see. 
 
 

 

 
 
To do: 
 
1. Highlight the whole 

spreadsheet or block of data 
2. Select Data > Subtotals from 

the menu 
3. Set the required sub-totalling 

criteria 
4. Click OK 
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To begin with, all rows are shown but if you click on button 2 , all the 
detail is hidden and the just the subtotals show…………. 

 
 
 

 

 
 
c) To reveal the detail behind the subtotals, click on one or more of the plus signs 
 
 
 
To remove subtotals: 
 
 Click on Data, Subtotals and then click the Remove all Subtotals button. 
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4.4 Filtering 
 
 
Filters are very handy when there are many rows and columns of data in an Excel 
spreadsheet.  A filter allows you narrow down the view of the data based on 
criteria you select.   
 
Before you begin filtering: 
 
a) Remove any subtotals 
b) Highlight the whole spreadsheet (or the data block) 
 
Then: 
 
c) From the menus select: Data > Filters >AutoFilter 
  This will automatically put little drop down arrows (the ‘filters’) next to each  

of your column headings 

 
d) to filter your data click an arrow and pick from the relevant drop down list,  

e.g. data for just cost centre NAAA 
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e) You could then apply filters to other columns if you wish  

e.g. filter by a particular cost centre and then by period 
 
f) When filters are applied, the Autosum function recognises the filters and acts 

differently: 
 
In the example below, instead of =sum(D1:D3604), only the filtered and 
displayed data is included in the sum – a subtotal for the filtered data is 
calculated 
 
Bonus feature:    When you apply a different filter, the sum total changes 

automatically 
 

Line numbers 
from your 
original 
spreadsheet 
that contain 
the required 
filtered 
information  

 
Useful Tips: 

• When a filter is on and the data is highlighted and copied to another sheet, 
only the filtered data is copied. 

• When the filter is on and the amount column is highlighted the sum of the  
transactions will only include the filtered data 

 
To get rid of the filters, simply position the cursor anywhere in the data and choose: 
Data, Filter, Auto-filter – to untick the feature. 
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4.5 Text To Columns function 
 
 
A particularly useful function for splitting up an account code string into its constituent 
segments. 
 
a) Insert additional blank columns to match the number of splits you want in the 

source data 
b) Make sure the column you want to split up is highlighted 
c) Select from the menu: Data> Text to Column 
 

 
      Step 1: 

 Ensure the “Delimited” 
       button is selected 
 
 
 

 
 
 
 
 
 
 

 
 
 

  
Step 2: 
Make sure the “Tab”  
box is ticked and there 
is a full stop in the  
“Other” box 
 
Step 3: 
In this example, we do  
not wish to import the  
column containing 0000,  
so click into the column  
and then click the “Do not 
 import column (skip)”  
button. 
 
 
 
Click “Finish”. In your spreadsheet, the single column will be replaced with the new columns 
of split data. 
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APPENDIX:
 
Excel navigation keys  

Key Description 

CTRL+* 

 

 

Selects the current region around the active cell (the data area enclosed by blank 
rows and blank columns).  

In a PivotTable, it selects the entire PivotTable report. 

CTRL+A Selects the entire worksheet.  

If the worksheet contains data, CTRL+A selects the current region. Pressing 
CTRL+A a second time selects the entire worksheet. 

When the insertion point is to the right of a function name in a formula, displays the 
Function Arguments dialog box. 

CTRL+SHIFT+A inserts the argument names and parentheses when the insertion 
point is to the right of a function name in a formula. 

CTRL+F Displays the Find dialog box.  

SHIFT+F5 also displays this dialog box, while SHIFT+F4 repeats the last Find 
action. 

CTRL+G  Displays the Go To dialog box.  

F5 also displays this dialog box. 

CTRL+H  Displays the Find and Replace dialog box. 

F5 Displays the Go To dialog box.  

Other useful shortcut keys 

Key Description 

ARROW 
KEYS 

Move one cell up, down, left, or right in a worksheet.  

CTRL+ARROW KEY moves to the edge of the current data region (data region: 
A range of cells that contains data and that is bounded by empty cells or 
datasheet borders.) in a worksheet. 

SHIFT+ARROW KEY extends the selection of cells by one cell. 

CTRL+SHIFT+ARROW KEY extends the selection of cells to the last nonblank 
cell in the same column or row as the active cell. 

LEFT ARROW or RIGHT ARROW selects the menu to the left or right when a 
menu is visible. When a submenu is open, these arrow keys switch between the 
main menu and the submenu. 

DOWN ARROW or UP ARROW selects the next or previous command when a 
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menu or submenu is open. 

In a dialog box, arrow keys move between options in an open drop-down list, or 
between options in a group of options. 

ALT+DOWN ARROW opens a selected drop-down list. 

END Moves to the cell in the lower-right corner of the window when SCROLL LOCK is 
turned on.  

 Also selects the last command on the menu when a menu or submenu is visible. 

CTRL+END moves to the last cell on a worksheet, in the lowest used row of the 
rightmost used column. 

CTRL+SHIFT+END extends the selection of cells to the last used cell on the 
worksheet (lower-right corner). 

HOME Moves to the beginning of a row in a worksheet.  

Moves to the cell in the upper-left corner of the window when SCROLL LOCK is 
turned on. 

Selects the first command on the menu when a menu or submenu is visible. 

CTRL+HOME moves to the beginning of a worksheet. 

CTRL+SHIFT+HOME extends the selection of cells to the beginning of the 
worksheet. 

PAGE 
DOWN 

Moves one screen down in a worksheet.  

ALT+PAGE DOWN moves one screen to the right in a worksheet. 

CTRL+PAGE DOWN moves to the next sheet in a workbook. 

CTRL+SHIFT+PAGE DOWN selects the current and next sheet in a workbook. 

PAGE UP Moves one screen up in a worksheet.  

ALT+PAGE UP moves one screen to the left in a worksheet. 

CTRL+PAGE UP moves to the previous sheet in a workbook. 

CTRL+SHIFT+PAGE UP selects the current and previous sheet in a workbook. 

SPACEBAR In a dialog box, performs the action for the selected button, or selects or clears a 
check box.  

CTRL+SPACEBAR selects an entire column in a worksheet. 

SHIFT+SPACEBAR selects an entire row in a worksheet. 

CTRL+SHIFT+SPACEBAR selects the entire worksheet.  
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 If the worksheet contains data, CTRL+SHIFT+SPACEBAR selects the 
current region. Pressing CTRL+SHIFT+SPACEBAR a second time selects the 
entire worksheet.  

 When an object is selected, CTRL+SHIFT+SPACEBAR selects all 
objects on a worksheet. 

ALT+SPACEBAR displays the Control menu for the Excel window. 
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