How to Excel with CUFS

Part 3

Course Manual
Contents

1 Financial Information
1.1 Data vs. Information 2
1.2 Attributes of Quality Information 2

2 Pivot Tables
2.1 What are they? 4
2.2 How to create them 5
2.3 The pivot table tool bar 9
2.4 Amending the level of detail displayed 10
2.5 Re-arranging the data displayed 12
2.6 Changing the fields displayed on the pivot table 13

3 Presenting Information
3.1 General Tips 16
3.2 Report Headers and Footers 16
3.3 Layout and Formats 17

4 Charts and Graphs
4.1 Basic Process 22
4.2 Improve the layout and look of a chart 23
4.3 Sizing and moving charts around 25
4.4 Creating charts from pivot tables 26

5 Security of spreadsheets
5.1 Passwords to restrict opening 27
5.2 Passwords to prevent changes 29
5.3 Removing password protection 29
1. Financial Information

1.1 Data vs. Information

There is a difference between these two terms, although often they are used interchangeably.

**Data:** these are the facts, events, transactions that are inputted into a system e.g. originating from the suppliers invoice, payroll system, cash receipt etc.

**Information:** This is data that has been processed in some way so that it is more meaningful to the end user, e.g. sorted, classified, formatted and enhanced.

The Importance of Financial Information

Insufficient or inadequate financial management information may lead to:

- Poor decisions being made
- No corrective action being taken

1.2 Attributes of Quality Information

Quality information should ‘add value’ when it is used, therefore you should be asking:

- Who will be using the information?
- Why do they want it?
- When do they need it by?
- What format do they require?

Once you have these answers you can then ensure that the information you produce contains all the right attributes.

The table overleaf lists them:
<table>
<thead>
<tr>
<th>Relevant for the purpose</th>
<th>Think about the issue being considered and what the information is to be used for e.g. is it to predict, to analyse, to summarise or to influence decisions. Remove any irrelevant data.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Completeness</td>
<td>All the information required for the decision making should be provided – it may be that well prepared, accurate - but incomplete information is worthless.</td>
</tr>
</tbody>
</table>
| Volume                  | The detail and volume of the information should be consistent with the needs of the user:  
|                         | ~Focus clearly on the issue  
|                         | ~Highlight the main points/ provide a summary  
|                         | ~Don’t cloud the issue with surplus data. |
| Accurate for the purpose| How exact do the values need to be?  
|                         | ~to the nearest penny, e.g. for a VAT invoice  
|                         | ~to the nearest pound e.g. for an aged debtors list  
|                         | ~to the nearest thousand pounds e.g. forecasting expenditure over the year |
| Reputable source        | Users must have confidence in the source of the information e.g.  
|                         | ~ it has been reliable in the past.  
|                         | ~ it is free from error or bias  
|                         | ~ it can be reconciled with CUFS! |
| Timely                  | Information should be issued within deadlines to allow for the user to consider or take any necessary corrective action e.g.  
|                         | ~before year-end,  
|                         | ~before a grant closes,  
|                         | ~before last date for deposit movements  
|                         | ~in advance of a meeting to discuss |
| Communicated through the | Think about the nature of the information (is it sensitive or complex), what is it’s purpose, the requirements of the user and the speed it is required and then select the appropriate delivery method, e.g.  
| most appropriate channel| ~hard copy report,  
|                         | ~e-mail,  
|                         | ~a meeting to discuss. |
| Communicated to the right | Information should be communicated to the right person e.g.  
| person                  | ~is a manager only responsible for one discreet area?  
|                         | ~is it to be forwarded to others? |
| Understandable          | Choose the style and language appropriate to the level and skill of the user. |
| Cost effective          | Remember the costs of providing the information should not outweigh the value added. |
2. Pivot Tables

2.1 What are they?

Pivot tables are interactive tables in Excel that can quickly summarise or cross-tabulate large amounts of data.

They allow you to:

- rotate rows and columns to see different layouts of the source data
- filter data and display with subtotals and show on different pages
- expand the pivot table to see details of one or more items
- drill down to create separate detailed data extracts
- create charts based on the data with a single click of the mouse

Pivot tables also allow you to specify how you would like the data summarised by using functions such as ‘count’, ‘sum’ and ‘average’. Subtotals and grand totals can be included automatically or you can define your own.

You can create a pivot table from:

- A Microsoft Excel list or database
- Multiple Excel worksheets
- An external database
- Another pivot table

Scenario:
In Excel, analyse departmental expenditure on source of funds AAAA (Chest Non-payroll) by exporting a standard report and creating a pivot table from the data.

Method:

Stage 1
a) Run the Transaction Code Balance Report - Exportable
b) Save as a Text file and open up in Word to remove page breaks
c) Import into Excel and save

Stage 2
d) Create a look up table that provides descriptions for the first two letters of the transaction codes starting with E and F
e) Insert three extra columns into the data spreadsheet and strip out the transaction code details
f) Using the left function extract the first two characters of the transaction code and look up their description

Stage 3
g) Select the whole sheet and go to Pivot Reports
h) Create a pivot report where page = cost centre, rows = category description and data = sum of period activity
2.2 How to create Pivot Tables

a) In Excel, highlight the data that you want to display in a Pivot table
(Note: Ensure all the columns in your data source have headings)

b) Select Data → Pivot Table and Pivot Chart Report from the menu:

c) Follow the Pivot table wizard:

In Step 1: select the data source and select a Pivot table (these are the default settings in step 1 of the wizard)
In Step 2: Make sure the range includes all of the rows and columns you wish to use for the pivot table. Click Next.

In Step 3: Click on Layout and decide which fields from the spreadsheet you would like to be displayed (this can always be changed later).

In the layout screen: Click and drag the row/column information from the selection available on the right hand side.

Amend this option from ‘Count’ to ‘Sum’ by double clicking it.

If when you transfer over a value field (in this case “Period Activity”) and it is displayed as a ‘count of …’ double click on the transferred field to change the
mathematical function of the field. The following box will be displayed, and you can choose whether you want your information counted, or, for example, summed.

If you then click on ‘OK’ you will return to the Layout box. Once you are satisfied with your Layout, clicking on ‘OK’ will return you to step 3.

This button allows you to format the cells, e.g. add £ signs, decimal places etc.

If you wish, you can then click into ‘Options’ to amend details such as whether subtotals and grand totals will be displayed.

Again, once you click on OK you will be returned to Step 3 of the Pivot Table Wizard.

**Click on Finish.**
Your Pivot Table will be displayed and you can then amend the displayed data as you wish.

When your cursor is in the region of the table the 'Field List' window pops up automatically. You can either close it down or just drag it to one side out of the way.

In this example, Transaction category balances are shown in a simple table. Note, this pivot table has the Cost Centre code as a Page item (cell A1) – the Cost Centre selection can be changed to show one, all or a selection of costs centres. The totals for each transaction code will then update according to the selections made.

It is quite easy to change the table so the cost centre totals for each transaction category are displayed in columns. Simply drag the shaded Cost Centre code box down into the table (just above the Total cell).
2.3 The Pivot Table Tool Bar

If the toolbar is not currently displayed either:

a) select it from the menu:
   View → Tool bars → Pivot Table

or

b) with your cursor in the pivot table, right click on your mouse and select “Show Pivot Table Toolbar”
2.4 Changing the level of detail displayed

If you double click on either a row or column field e.g. "Agricultural..." an additional Show Detail window will appear and allow you to add more details to your report. Alternatively you can use the “show” and “hide details” buttons on the pivot table tool bar.

In the example below the 'Transaction Description' has been added.

Now if you double click on any individual transaction category description you see its related transaction descriptions.

If you double click on one of the values, Excel will provide you with a breakdown on a new sheet of the component entries from your original spreadsheet.
Excel gathers all the lines of data that make up the total in the pivot table and displays it on a new sheet (or tab). So if you clicked on ten different totals in the pivot table, you would create ten additional sheets in the Excel work book

**Tip:** Be careful to delete any additional sheets that you no longer require – Excel workbooks containing pivot tables can double in size compared to those containing just the raw data.
2.5 Re-arranging the data displayed

The grey ‘Field Buttons’ can be used to rearrange the data. Each field summarises multiple rows of information from the original data source. By dragging a field button to another part of the table allows you to view the data in different ways.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sum of Period £</td>
<td>Cost Centre</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Car Name</td>
<td>Trans. Code</td>
<td>Description</td>
<td>AGAA</td>
<td>AGBA</td>
<td>AGBB</td>
<td>AGBC</td>
</tr>
<tr>
<td>3</td>
<td>AUDIO V</td>
<td>EAA</td>
<td>Photographic Film</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>EAA Total</td>
<td></td>
<td></td>
<td>0</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>AUDIO VISUAL EQUIPMENT Total</td>
<td></td>
<td></td>
<td>0</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>BOOKS</td>
<td></td>
<td></td>
<td>0</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>BROUGHT IN &amp; PROF SERVICES</td>
<td></td>
<td></td>
<td>-9310.95</td>
<td>566</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>CATERING</td>
<td>56.1</td>
<td></td>
<td>159.47</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>CLEANING</td>
<td></td>
<td></td>
<td>0</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>COMPUTER</td>
<td>0</td>
<td>5603.52</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>ESTATES</td>
<td>0</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>FURNITURE</td>
<td>0</td>
<td>0</td>
<td>333</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>HEALTH &amp; SAFETY</td>
<td>0</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>MISCLASSIFIED</td>
<td>-367.32</td>
<td>104.9</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>POSTAL &amp; TELECOMS</td>
<td>299.96</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>PRINTING</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>STATIONERY</td>
<td>13.68</td>
<td>-1234.1</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>TRAVEL</td>
<td>285.2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>WORKSHOP</td>
<td>9.75</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Dragging the cost centre field button from D1 to A2 can create a different layout.
2.6 Changing the fields displayed on the pivot table

You can amend your pivot table and change the fields that are displayed by either adding new ones or removing existing ones.

The two most common ways to change the fields displayed in the pivot table are…

Method 1

From the Pivot tool bar click on the ‘show field list’ icon

This will display a list of all the available fields.

(items in bold are already displayed on your pivot table)

Either:

- highlight a field and drag it to the required location on your spreadsheet;

or

- using the Add To button, select where you want to add the new field – from the drop down list and then double click on the appropriate field from the list.
Method 2

- On the Pivot tool bar select Pivot table wizard from the drop down menu selection.

- This will take you back to step 3 of the initial wizard and you can amend which fields you would like displayed (and where) by dragging the field buttons across.

- When you have made the changes, click on OK and decide whether you would like your new pivot table report on the same sheet or on a new one. (Step 3 of the wizard).

Alternatively, you modify the layout by simply dragging and dropping an item to another area of the pivot table.
To ‘Hide’ blank fields that contain no data….

1. Click on the drop down arrow next to the heading of the blank field e.g. in this example ‘Activity Description’

2. Scroll down and untick the ‘blank’ option

3. Click on OK
3. Presenting Information

3.1 General Tips

There are a number of ways that data can be presented - and Excel can help you with this - but in all circumstances information should be:

**Clear:** Take account of the users’ abilities, aggregate and classify if appropriate, provide summaries of key issues and supporting explanatory notes.

**Comparable:** Consistent, standardised, regular formats, layouts. Notes to assist interpretation particularly where there are changes in treatment with comparable figures – e.g. from a prior period.

3.2 Report Headers and Footers

It sounds obvious but you should always include a title for your report that includes – as a minimum - details of your department, the account segment(s) being analysed and the time period that the data covers.

**Tip:** You may simply type in titles at the top of a sheet, but using the Header and Footer options allows you to automate the display of file names and dates.

From the menu bar select: “View” and then select “Header and Footer”
If you are creating your own header you will progress to this screen, where you can type in the title you require.

Once you have created this header it will be added to the drop down list of standard headers (such as Filename, Date etc) and is available for all the other sheets within your workbook.

![Header Dialog Box]

**Report Footers**

Useful for both the report author and customer; these can include references such as:

- The name of the person who has compiled the report,
- Date prepared and version number
- Excel filename
- Page numbering

Go to: “View” menu and select “Header/Footer” and the process is the same as for a header.

### 3.3 Layouts and formats

You can improve the look and clarity of your report by altering its format, fonts, backgrounds and introducing colours. This can be done either manually or by clicking on the auto format button in the pivot table tool bar.

From here you can select one of the standard report layouts from the menu options.
Getting Column titles to repeat at the top of each page

Often you will have a spreadsheet that contains many rows of data which will thus print out over several pages. You can get Excel to repeat the column headings from the first page on each subsequent page that you print.

From the “View” menu go to the “Header/Footer” option
Select the ‘Sheet’ tab:

Enter the reference for the row on your spreadsheet that contains your column titles, e.g. $1:$1 is row 1 (alternatively you could just highlight the row on the spreadsheet)
Then just click OK

Formatting numbers/currencies

There are a number of ways in which you can format values.

To quickly convert to £0.00 format, highlight the cells and click on the currency button on the tool bar

To choose a specific currency format, highlight the cells and select “Format”, “Number”

Choose a category e.g. Currency, and modify it using the options

Alternatively, choose the last category called “Custom”, and then pick a display option from the long scroll down list.
Note:

Standard practice is not to include the currency symbol for each value - but to specify it at the top of the column.

Highlighting data

Method 1

With your mouse, select the range of cells you wish to highlight.

From the tool bar click on the “Fill” button

Method 2: Use “Conditional Formatting”

Let Excel highlight values that meet criteria you specify. Firstly, select the data area you want the conditional formatting to operate on then:

Select “Format”, “Conditional Formatting”

select the criteria you would like to use from the drop down lists:
For example, if you want it to highlight any values greater than £1,000 you would complete the boxes as follows:

![Conditional Formatting dialog box](image)

Now specify how you want the results highlighted by clicking on the format Button.

**Adding a “Comment” to a cell**

Adding comments to spreadsheet cells allow notes to be added without typing directly into a cell. The comment is typed into a pop-up box. You can then choose how to display options the comments. For example, they can be permanently displayed or just be indicated by a small red triangle.

![Spreadsheet cells with comments](image)

Place your cursor over this red triangle the comment is displayed.
How to add a comment

Click in the cell where you would like to add a comment and either right click on the mouse or go to the Insert menu and select 'Insert Comment'.

Do the same to edit/delete an existing comment.

To list the comments at the end of the worksheet (when printed out), go to:

File> Page Set Up and select the 'Sheet' tab

For Comments, select ‘at end of sheet’
4. Charts and Graphs

Sometimes a chart may be a better way of displaying information giving more clarity with a visual presentation of data.

4.1 Basic process

a) Highlight your data (including column/row labels)

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period</td>
<td>FYE 04/05</td>
<td>FYE 03/04</td>
</tr>
<tr>
<td>AUG</td>
<td>119,853.66</td>
<td>153,648.29</td>
</tr>
<tr>
<td>SEP</td>
<td>62,750.06</td>
<td>69,500.26</td>
</tr>
<tr>
<td>OCT</td>
<td>154,198.63</td>
<td>60,544.12</td>
</tr>
<tr>
<td>NOV</td>
<td>62,827.95</td>
<td>277,523.33</td>
</tr>
<tr>
<td>DEC</td>
<td>94,619.66</td>
<td>78,729.06</td>
</tr>
<tr>
<td>JAN</td>
<td>86,084.51</td>
<td>61,532.09</td>
</tr>
<tr>
<td>FEB</td>
<td>64,265.34</td>
<td>135,160.56</td>
</tr>
<tr>
<td>MAR</td>
<td>62,820.02</td>
<td>99,672.25</td>
</tr>
<tr>
<td>APR</td>
<td>63,007.33</td>
<td>56,172.93</td>
</tr>
<tr>
<td>MAY</td>
<td>76,136.63</td>
<td>111,619.80</td>
</tr>
<tr>
<td>JUN</td>
<td>0</td>
<td>71,744.12</td>
</tr>
<tr>
<td>JUL</td>
<td>0</td>
<td>-168,733.59</td>
</tr>
</tbody>
</table>

b) From the menu bar, select **Insert → Chart** or click on the **Chart button** on your tool bar

c) Using the Chart wizard steps, select the type of chart you want and select the data source

d) Titles and Axis labels – you should always ensure that your chart has a title and its axes are labelled.
4.2 Improve the layout and look of a chart

With the chart displayed, double click on one of the axes labels (e.g. a period name), the formatting box will appear.

Select the ‘Patterns’ tab

Make sure the major tick mark type is ‘outside’
and
the tick mark label is ‘low’

Now click on OK

The axis labels have now moved to the bottom of the chart.

Data labels

Like chart titles, these are a chart option and can either be set up in the wizard steps or afterwards by selecting chart options (right clicking on your mouse).

When adding labels, be careful that they don’t clutter up your chart and make it difficult to read (especially on bar charts) – consider reformatting the labels so that they use a different font, colour or size.

Tip: Labels work particularly well with pie charts – see example overleaf.
Change the format of any existing titles, labels etc on your graph

Either highlight the item e.g. a data label and double click or pick the item you require from the chart objects tool bar button and then click on format.

A format window will then appear similar to below.
4.3 Sizing and moving charts around

It is easy to resize and move charts around charts that have been inserted into existing pages of a workbook or another file.

To resize

Highlight your chart and place your cursor over one of the black squares on the boundary until your cursor becomes a small double headed arrow. Now just drag either in or out until you reach the required size.

To move a chart:

Click anywhere in the chart area, hold down the left mouse key down and drag the chart to the required spot.

Copying into a word document:

Highlight the chart and then copy and paste into the required document.
4.4 Creating Charts from Pivot tables

You can also chart the data in your pivot table. Simply highlight the data in your pivot table that you would like to chart and click on the charting button in the Pivot tool bar.

Select the required style of chart and amend the format, colour, labelling, size etc. until you are happy. It is recommended that you save your chart as a different worksheet initially and don’t forget to give it a header and footer in the normal way.

Your chart will automatically update itself to reflect your pivot table view.
5 Security of spreadsheets

If you export data from CUFS you must ensure that it continues to be kept in a secure manner.

In Excel you can set passwords to restrict both viewing and updating of spreadsheets that may contain sensitive departmental or personal information.

Hardcopy reports and spreadsheets containing such information should never be left out or kept unsecured.

5.1 Passwords to restrict opening a spreadsheet

i) Open up the spreadsheet in question
ii) From the file menu select Save As
iii) Click on the Tools and select General Options from the menu

![Image of Save Options dialog box]

In the pop-up window that appears, type in the password you wish to use.

(This does not have to be a minimum length but it is case sensitive)
e) You will return to your main “Save As” window – now just click on the Save button

![Save As dialog box]

Say “Yes” to the message that pops up and replace your existing file. Your password is now set.

Next time you open the file you will be asked for the password

**WARNING:** Passwords are case sensitive and they are stronger if you include numbers, symbols and mixed case. HOWEVER, if you forget your password, you may have to resort to code breaking software to get it back (at a price)

**TIP:** If the data is not sensitive, then just protect your work from being altered (see overleaf.)
5.2 Adding passwords to prevent changes

a) Repeat the process detailed above but add a password into the second field

b) When you open the spreadsheet you will have to go through two password screens, the second being:

c) To update the spreadsheet enter the second password and click OK

d) To just view the spreadsheet click on ‘Read Only’

5.3 Removing password protection

a) Open up the spreadsheet in the normal way
b) Select Save as from the File menu
c) Select General Options from the Tool button
d) Delete any existing passwords entered
e) Click on OK
f) Click on Save